Ditto X4 Unmounting, Audio Glitches, Midi Sync, Mac files, Drones

Ditto X4 Unmounting, Audio Glitches, Midi Sync, Mac files, Drones

Only had the DittoX4 for two weeks and have had a few issues ( ha, sound familiar? ). This is in conjunction with a mac computer and firmware 1.3 build 89 – can’t update because PC only

1. Have had three different explanations for mounting the Ditto for firmware update. Basically connect usb to computer, hold down loop1 and apply power, wait till all leds go green. Open firmware app. The update is finished when the app says  100% and all leds go out – don’t be confused by the still animating progress bar.

2. After connecting the ditto to the computer to copy audio files dragging the icon to the trash to dismount the drive does nothing, the icon disappears for a second then pops back up – very confusing. Just pull the usb lead out and the ditto will process files if needed.

3. Some audio files won’t transfer to the Ditto. This seems to be related to the software generating the files. I found two apps I used failed and two others worked. If this is a problem for you try opening and saving the files in Audacity ( freeware ) or WAV fixer or Switch apps. This may be a file header problem?

4. I am getting a glitch in my loops. This didn’t happen when I first got my Ditto so maybe it started after I updated from V 1.1 to 1.3. To start with my loops had a nice fade in and fade out which stopped any glitch noises. Now the start of the loops is flat for a couple of milliseconds then suddenly cuts into the waveform.

5. Midi sync. The ditto responds to midi clock. This is 24 pulses per quarter note. The stop led flashes in bars. The question is does the Ditto synchronise recordings to bars or midi clock pulses when recording with midi sync. I feed the ditto an audio loop with a synchronised midi clock signal and tried a number of recordings. The audio loop was 8 seconds long. My first recording was 8.007 sec long, my second was 8.044 sec long, my third was 8.006 sec long. The ditto should really calculate bars from your initial switch press and end the recording after 24 x 4 ( or 8 or 16 ) midi clock pulses when the press the loop button again.
Another thing i tried was loading an 8 second loop into loop1 and recording loop2 with various midi scenarios.
1. with midi connected and bpm synchronised to 8 sec loop and loop1 playing the loop2 recording was exactly 8 sec long and had crossfade looping.
2. without midi connected but with loop1 playing the loop2 recording was exactly 8 sec long but had a glitch at the beginning ( the fault mentioned previously ).
3. with midi connected but not playing loop1 the loop 2 recording didn’t end up being exactly 8 seconds long.

6. With the results above people may be able to record good looping drones by preloading the ditto with a loop of silence duration set from a known bpm then feed the ditto with a midi clock at that bpm then record the drone sound to loop2. The crossfade looping should make this work but it all sounds a bit hard.

7. One final thing, I assume the SD card inside the ditto also stores the firmware so if this gets dislodged or gets an error thats the machine refuses to work – I’m only hypothesising, there will be dittos with other hardware faults.

looking forward to testing the new firmware at some stage

read more

Source: http://forum.tcelectronic.com