PolyTune 3 LED / Firmware Update Issue

PolyTune 3 LED / Firmware Update Issue

I spent 15 minutes trying to open a support request. After getting to the end and clicking “Submit”, here’s what I got:

It seems we can’t find the page you’re looking for.
The page may have been moved or deleted
The link you have may be broken or incomplete
You may have mistyped the URL.
Click here to go back to the home page.

Where do I go from there?

Here’s my query:


Instructions in manual were followed. I found that when holding down the footswitch and plugging in the DC power, the LED did not come on. The same was true in normal operation without the USB cable plugged into the tuner.

I found I had to plug an instrument cable into the input jack to get the PolyTune 3 to boot. This made Windows recognize the tuner and install drivers. I still had no LED–the driver setup is the only indication I had that the tuner was booting.

I ran the  firmware updater anyway. The firmware updater went to 100% and said “update completed”, and the tuner appeared to reboot. At that point, the LED did come on.

Any idea why I’d see this LED behavior?

Is there any way to determine if the firmware update worked? To check the installed version?

Thank you.

read more

Source: http://forum.tcelectronic.com